CISA warns of remote code execution vulnerability with Discourse

Open Source

CISA urged developers to update Discourse versions 2.7.8 and earlier in a notice sent out on Sunday, warning that a remote code execution vulnerability was tagged as “critical.” 

The issue was patched on Friday, and developers explained that CVE-2021-41163 involved “a validation bug in the upstream aws-sdk-sns gem” that could “lead to RCE in Discourse via a maliciously crafted request.”

Developers noted that to work around the issue without updating, “requests with a path starting /webhooks/aws could be blocked at an upstream proxy.”

The popular open source discussion platform attracts millions of users every month, prompting the message from CISA urging updates to be pushed through. 

Researchers have detailed the finer points of the problem in blog posts and reported the issue to Discourse, which did not respond to requests for comment. 

BleepingComputer conducted a search on Shodan that found all Discourse SaaS instances have been patched. 

Saryu Nayyar, CEO of cybersecurity company Gurucul, said Discourse “continues to make news after researchers discovered a vulnerability that enabled attackers to invoke OS commands at the Administrator level.” 

“It’s critically important for both systems administrators and individual users to keep up with security information from software providers and to install

Read More: https://www.zdnet.com/article/cisa-warns-of-remote-code-execution-vulnerability-with-discourse/#ftag=RSSbaffb68